Scheduled Maintenance

Scheduled

Scheduled Maintenance

Status: closed
Start:
End:
Duration: 56 minutes
Affected Components:
Web application Log in & access
Update

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Customers will not be able to log into our site, use the application, or send emails during this maintenance window. For more details, please visit our FAQ.

To be notified of future status and maintenance updates, please subscribe.

Update

We will be undergoing scheduled maintenance on Sunday, 8th May 2022 at 04:00 AM UTC (see your timezone here) which will last approximately 1 hour.

Customers may experience interruptions when logged into their account during maintenance. Emails scheduled will continue to send during the maintenance window. We encourage you to pass this information along to any additional users on your account who may not see this message.

To be notified of future status and maintenance updates, please subscribe.

Resolved

We have completed our scheduled maintenance. Emails that were queued to send during the maintenance window may have been delayed. Users may temporarily see some residual slowness in the app.

To be notified of future status and maintenance updates, please subscribe.