Marketing website unavailable

Performance

Marketing website unavailable

Status: closed
Start:
End:
Duration: 35 minutes
Affected Components:
Marketing website
Update

Our marketing website at campaignmonitor.com is currently offline. We are working to restore it as soon as possible. Access to your account, sending, and all other functionality remains uninterrupted. Thanks for your patience.

Resolved

Our marketing site at campaignmonitor.com is now online and should be accessible again. Access to your account, email sending, and other functionality was not affected by this. The issue affected the campaignmonitor.com domain only.