Error Processing Payment

Performance

Error Processing Payment

Status: closed
Start:
End:
Duration: 7 hours 23 minutes
Affected Components:
Web application Payment processing
Update

We’ve received reports that some customers are having trouble processing card payments. We are currently investigating and will keep you updated.

Update

Some customers may experience delays in payment processing and issues adding new payment details to clients in agency accounts. We are working on a fix and will continue to provide updates.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience issues with processing card payments, though we are monitoring results.

Resolved

The incident has now been resolved. Customers should no longer experience issues processing payments or adding payment details.