Issues affecting credit card payments

Performance

Issues affecting credit card payments

Status: closed
Start:
End:
Duration: 37 minutes
Affected Components:
Web application Payment processing
Update

Some customers may have trouble adding their card to make a payment. We are currently investigating and will keep you updated.

Update

Successful transactions are now coming through. Please try adding your card or sending your campaign again.

Resolved

This issue has now been resolved. Customers should no longer experience any problems when adding a credit card, or otherwise initiating a payment.