Journey sending delays

Incident

Journey sending delays

Status: closed
Start:
End:
Duration: 4 hours 30 minutes
Affected Components:
Email sending Journey emails
Update

Some accounts are currently experiencing journey sending delays of 3-4 hours.

Resolved

The incident has now been resolved and all journey emails that were delayed have now been sent. Sending has returned to normal, but journey emails may have sent up to 4 hours late during this period.