Some delays in sending campaigns

Incident

Some delays in sending campaigns

Status: closed
Start:
End:
Duration: 40 minutes
Affected Components:
Email sending Campaign emails
Update

Some customers may currently experience a short delay when sending a campaign. The majority of campaigns are sending without any issues, in isolated cases we are seeing a delay of around 30 minutes. We are working to resolve this as soon as we can. Thanks for your patience.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience any delays sending campaigns, though we are monitoring results.

Resolved

The incident has now been resolved. Customers should no longer experience any delays sending campaigns.