Help Center websites unavailable

Incident

Help Center websites unavailable

Status: closed
Start:
End:
Duration: 31 minutes
Affected Components:
Help Center
Update

Our help center websites are currently offline. We are working to restore these sites as soon as possible. Access to your account, sending, and all other functionality remains uninterrupted. Thanks for your patience.

Resolved

Our help center sites are now online and should be accessible again. Access to your account, email sending, and other functionality was not affected by this.