Issues accessing Clients page in agency accounts

Incident

Issues accessing Clients page in agency accounts

Status: closed
Start:
End:
Duration: 31 minutes
Affected Components:
Web application Campaign creation & previews Campaign reporting (opens, clicks, Worldview) Email builder Design & spam testing Journey builder RSS feed reader Transactional reporting Lists & subscribers Segment processing Signup forms Insights Templates Log in & access Payment processing Email image hosting CSS & JavaScript
Update

Some agency accounts may not be able to load their clients page. We are currently investigating and will keep you updated.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Agency customers should no longer experience issues loading their clients page, though we are monitoring results.

Resolved

The incident has now been resolved. Agency customers should no longer experience issues loading their clients page.