Marketing website unavailable

Incident

Marketing website unavailable

Status: closed
Start:
End:
Duration: 50 minutes
Affected Components:
Marketing website
Update

Our website at campaignmonitor.com is currently unavailable. Users can still log in via https://login.createsend.com/l. We are working to resolve this as soon as we can. Thanks for your patience.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience issues accessing campaignmonitor.com, though we are monitoring results.

Resolved

The incident has now been resolved. Users should no longer experience issues accessing campaignmonitor.com.