Email Builder & Insights issues

Incident

Email Builder & Insights issues

Status: closed
Start:
End:
Duration: 2 days 20 hours 23 minutes
Affected Components:
Web application Email builder Insights
Update

Some customers may be currently experiencing issues when attempting to open or edit emails in the drag-and-drop Email Builder. We are currently investigating, working to resolve this as soon as we can. Thanks for your patience.

Update

We're working to resolve the issues some customers are seeing in the drag-and-drop Email Builder. Thanks for your patience. Insights may also have trouble loading in some accounts. We're hoping to have everything fixed as soon as possible.

Update

A fix has been implemented and the Email Builder should be loading without issue again when opening and editing emails. We're still seeing issues with Insights though, which we are currently working to address.

Update

A fix has been implemented for both the Email Builder and Insights reporting and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience problems accessing the Email Builder or Insights reports though we are monitoring results.

Update

An interim fix has been implemented to ensure customers are not impacted and access to the Email Builder and Insights has been restored. Our engineering team will continue to work on the root cause and we'll provide a further update when a full resolution has been implemented.

Resolved

We have implemented a permanent fix and this issue is now resolved. Customers should no longer experience any issues with access to the Email Builder or Insights.