Issues adding payment cards
Incident
2023-05-09T16:03:00.0000000Z
Issues adding payment cards
Status: closed
Start:
2023-05-09T15:02:29.9830000Z
End:
2023-05-09T16:03:00.0000000Z
Duration: 1 hour
Affected Components:
Web application
Payment processing
Update
2023-05-09T15:02:29.9830000Z
2023-05-09T15:02:29.9830000Z
We’ve received reports that some customers are having trouble adding new payment cards to accounts. We are currently investigating and will keep you updated.
Resolved
2023-05-09T16:03:00.0000000Z
2023-05-09T16:03:00.0000000Z
The incident has now been resolved. Customers should no longer experience issues adding payment cards. If you are still unable to add a card, please contact your card provider and let them know the authorization hold from Campaign Monitor is legitimate.
Copyright (C) 2024.