Phone support unavailable

Incident

Phone support unavailable

Status: closed
Start:
End:
Duration: 19 minutes
Affected Components:
Help Center
Update

The system we use to provide Premier phone support is currently offline. We are working to resolve this as soon as we can. Any users needing technical support can contact us through the in-app "Get support" option in the meantime. Thanks for your patience.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience issues contacting Premier phone support, though we are monitoring results.

Resolved

The incident has now been resolved. Customers should no longer experience issues contacting the Premier phone support line.