System delays

Incident

System delays

Status: closed
Start:
End:
Duration: 2 hours 23 minutes
Affected Components:
Web application Email sending API Campaign emails API endpoints Campaign reporting (opens, clicks, Worldview) Journey emails Lists & subscribers Segment processing
Update

Our system is experiencing issues where processing subscribers, segments, and tracking opens and clicks is currently delayed. Some campaign and journey sending is also affected. Some API calls may also be affected. Our team is working to resolve the issue as soon as possible.

Resolved

The issue is now resolved, processes concerning subscribers and segments, as well as open and click tracking, have now all caught up. All emails have now sent, although some may have been delayed for up to 90 minutes. API calls may have also been delayed, or timed out, or experienced server issues during the affected window.