Issues adding payment cards
Incident
2023-11-13T18:48:00.0000000Z
Issues adding payment cards
Status: closed
Start:
2023-11-13T17:44:00.0000000Z
End:
2023-11-13T18:48:00.0000000Z
Duration: 1 hour 4 minutes
Affected Components:
Web application
Payment processing
Update
2023-11-13T17:44:00.0000000Z
2023-11-13T17:44:00.0000000Z
We’ve received reports that some customers are having trouble adding Mastercard payment cards. We recommend that any users encountering this error contact their card provider for assistance. We are currently investigating and will keep you updated.
Resolved
2023-11-13T18:48:00.0000000Z
2023-11-13T18:48:00.0000000Z
The incident has now been resolved. Customers experiencing errors with Mastercard payment cards should contact their card provider for assistance.
Copyright (C) 2024.