Issue affecting campaign sending, webhooks, and overall application performance

Incident

Issue affecting campaign sending, webhooks, and overall application performance

Status: closed
Start:
End:
Duration: 5 hours 31 minutes
Affected Components:
Web application Email sending API Campaign emails Webhooks Log in & access
Update

We're currently experiencing a system issue affecting the sending of some webhooks and email campaigns. Customers may also experience errors or timeouts when navigating their account. We're currently working to resolve this as soon as possible.

Update

The system has now returned to normal and customers should no longer experience any errors or timeouts. Affected email campaigns have been sent, though some delayed. We are currently working through the queue of webhook events.

Resolved

The issue is now resolved. Webhooks processing has now caught up, except some that should have fired between 16:40 and 18:15 UTC were lost.