Scheduled Maintenance

Scheduled

Scheduled Maintenance

Status: closed
Start:
End:
Duration: 1 hour 47 minutes
Affected Components:
Web application Email sending Campaign emails Transactional emails Email builder Journey emails Preview emails Log in & access
Update

We will be undergoing scheduled maintenance on Sunday, 19 May 2024 at 04:00 AM UTC (see your timezone here) which will last approximately 2 hours. Our application will become unavailable during this maintenance.

All emails scheduled to send during the maintenance will be delayed. Custom domain certificate renewals and permanent erasure requests will also be delayed. Customers may experience interruptions when logged into their account.

We encourage you to pass this information along to any additional users on your account who may not see this message.

To be notified of future status and maintenance updates, please subscribe.

Update

The maintenance task is now done but our engineers are currently verifying that everything is working as expected before resolving the status page. Thanks for your patience.

To be notified of future status and maintenance updates, please subscribe.

Resolved

We have completed our scheduled maintenance. Emails that were queued to send during the maintenance window have now been sent. Users may temporarily see some residual slowness in the app.

To be notified of future status and maintenance updates, please subscribe.