Delays sending Transactional and login verification emails

Incident

Delays sending Transactional and login verification emails

Status: closed
Start:
End:
Duration: 1 hour 15 minutes
Affected Components:
Email sending Transactional emails
Update

Some customers may currently experience delays sending Transactional emails. We are working to resolve this as soon as we can. Emails already triggered to send will not need to be re-triggered once the issue is resolved. This problem will also impact password reset emails and other verification emails sent by Campaign Monitor, which may also be delayed. Thanks for your patience.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience delays sending transactional and receiving system emails, though we are monitoring results.

Resolved

The incident has now been resolved. Customers should no longer experience delays sending transactional emails or receiving password and verification emails.