Delays in email delivery to contacts with Yahoo or Yahoo-affiliated email addresses

Incident

Delays in email delivery to contacts with Yahoo or Yahoo-affiliated email addresses

Status: closed
Start:
End:
Duration: 5 hours 57 minutes
Affected Components:
Email sending Campaign emails Transactional emails Journey emails Preview emails
Update

This morning at approximately 8:30am ET, we noticed some delays in email delivery to contacts with Yahoo or Yahoo-affiliated email addresses. Yahoo is aware and actively investigating the root cause. You may experience longer than usual sending times for mail sent, and potentially lower open rates initially as a result. Once resolved, campaigns are expected to be delivered, however, we'll continue to monitor.

Resolved

This issue is now fully resolved.

Out of precaution, we will continue to monitor throughout the day and provide updates only if necessary.