Issues sending test emails

Incident

Issues sending test emails

Status: closed
Start:
End:
Duration: 1 hour 25 minutes
Affected Components:
Email sending Preview emails
Update

We’ve received reports that some customers are having trouble sending test emails. We are currently investigating and will keep you updated.

Update

We are continuing to work on a fix and will provide further updates. Customers may currently experience issues sending test emails.

Update

A fix has been implemented and we are verifying that everything is working as expected before resolving the status page. Customers should no longer experience issues receiving test emails though we are monitoring results.

Resolved

The incident has now been resolved. Customers should no longer experience issues receiving test emails.