Issue processing payments

Incident

Issue processing payments

Status: closed
Start:
End:
Duration: 1 hour 42 minutes
Affected Components:
Web application Payment processing
Update

Some customers may experience issues with processing payments and adding credit cards. This is due to an issue affecting payment processor Braintree (A PayPal Service).

Resolved

The service disruption affecting payment processor Braintree (A PayPal Service) has been resolved. Customers should no longer experience issues with payment processing or adding credit cards.