Delays importing subscribers

Incident

Delays importing subscribers

Status: closed
Start:
End:
Duration: 1 hour 24 minutes
Affected Components:
Web application Lists & subscribers
Update

Some customers may currently experience delays when importing subscribers. We are working to resolve this as soon as we can. Thanks for your patience.

Update

Our engineering team have been able to ensure that subscribers can be imported successfully. We are currently investigating the root cause to avoid any further issues.

Resolved

Our engineering team have resolved the problem here and there are no further issues importing subscribers.