Subscriber imports are delayed
Incident
2026-03-03T10:27:00.0000000Z
Subscriber imports are delayed
Status: closed
Start:
2026-03-03T08:35:00.0000000Z
End:
2026-03-03T10:27:00.0000000Z
Duration: 1 hour 52 minutes
Affected Components:
Web application
Lists & subscribers
Update
2026-03-03T08:35:00.0000000Z
2026-03-03T08:35:00.0000000Z
Customers may experience issues importing subscribers to a list. Imports are processing, but they are taking much longer than normal.
Resolved
2026-03-03T10:27:00.0000000Z
2026-03-03T10:27:00.0000000Z
Our engineering team have been able to resolve the issue and imports are now processing normally.
Copyright (C) 2024.