Microsoft delivery delays — customer update

Informational

Microsoft delivery delays — customer update

Status: in progress
Date:
Affected Components:
Email sending Campaign emails Transactional emails Journey emails Preview emails
Update

We're aware of an issue currently affecting email delivery to Microsoft domains (Outlook, Hotmail, Live). This is a receiver-side issue on Microsoft's end and is being seen industry-wide, with multiple email providers reporting the same behaviour this morning. It is not an indication of a problem with your account, your sending, or our platform.

We've raised this directly with Microsoft and are awaiting their response. Mail to other providers is unaffected. We'll share an update as soon as we hear back.

Thanks for your patience.


Update

We are continuing to monitor delivery of emails to Microsoft domains. Whilst we have seen some improvement and many emails are getting through, there is unfortunately continues to be a proportion of emails not being delivered successfully.

We'll share an update as soon as we have more information.